Chat problem

User avatar
marmor
Registered User
Registered User
Posts: 5
Joined: Thu Dec 31, 2015 10:55 am
Flag: Sweden

Chat problem

Post by marmor » Fri Jan 08, 2016 8:03 am

I think this problem is host created and cant be solved but i give it a try
I got a private web and file server at home,running Ubuntu server that mostly is used for template designs and testing purposes , using latest phpbb 3.1.6
and this chat, it works perfect ,

however installing the chat on my live site on x10 . creates a problem, on index page chat shows as wanted but noting u type show up its not the font color, what u type simple ends up nowhere and chat center link at top basically make a weird index of page, no chat at all. but seeing i got exact copy of webpage on my private server it most be host created, i think any suggestions?


User avatar
spaceace
Site Owner
Site Owner
Posts: 908
Joined: Wed Dec 16, 2009 8:30 pm
Location: Ontario, Canada
Flag: Canada
Contact:

Re: Chat problem

Post by spaceace » Fri Jan 08, 2016 4:34 pm

not sure what to say as some hosts will not allow any type of chat to run on their system as it can put a fair amount of load on the CPU. so some will block the functions of chat. without knowing the host you have or seeing exactly what's going wrong makes it hard to say
if you like my work and would like to contribute to my development of styles, please donate by using the donate button in the header.

Image

Image

User avatar
spaceace
Site Owner
Site Owner
Posts: 908
Joined: Wed Dec 16, 2009 8:30 pm
Location: Ontario, Canada
Flag: Canada
Contact:

Re: Chat problem

Post by spaceace » Sat Jan 09, 2016 2:46 pm

i just set up a free x10 site to test my chat on and it works perfectly running phpBB 3.1.6 with my Ajax Chat 3.0.10

you can see it here Ajax Chat x10 Hosting - Index page
if you like my work and would like to contribute to my development of styles, please donate by using the donate button in the header.

Image

Image

User avatar
marmor
Registered User
Registered User
Posts: 5
Joined: Thu Dec 31, 2015 10:55 am
Flag: Sweden

Re: Chat problem

Post by marmor » Sat Jan 09, 2016 3:04 pm

now that is weird i get similar problems no matter if i use your chat or try mchat

Saracen Knights AKA Sovereignty - Index page

login using
testuser
chatpls
Last edited by marmor on Sat Jan 09, 2016 3:05 pm, edited 1 time in total.

User avatar
spaceace
Site Owner
Site Owner
Posts: 908
Joined: Wed Dec 16, 2009 8:30 pm
Location: Ontario, Canada
Flag: Canada
Contact:

Re: Chat problem

Post by spaceace » Sat Jan 09, 2016 3:26 pm

to be honest, i don't know what is stopping chat from working unless it has something to do with the front end you have phpBB installed under that is preventing the routing. did you try any other extensions that use routing? like the rules extension or pages?
if you like my work and would like to contribute to my development of styles, please donate by using the donate button in the header.

Image

Image

User avatar
marmor
Registered User
Registered User
Posts: 5
Joined: Thu Dec 31, 2015 10:55 am
Flag: Sweden

Re: Chat problem

Post by marmor » Sat Jan 09, 2016 3:36 pm

only ting i tried is this chat and mchat, and every setting i can think of xd ,but the replica site on my own server server everything works on, to make it even weirder i checkt the database, phpbb_ajax_chat is empty, so can it be a database communication error of some sort, i kinda given up finding out what causing this myself, im totally out of ideas
Last edited by marmor on Sat Jan 09, 2016 3:53 pm, edited 1 time in total.

User avatar
marmor
Registered User
Registered User
Posts: 5
Joined: Thu Dec 31, 2015 10:55 am
Flag: Sweden

Re: Chat problem

Post by marmor » Sat Jan 09, 2016 5:00 pm

got it to work the hard way, i reinstalled the forum , new database everything, now i just need to manually import all posts and users , , and hope it still works so i can close down old forum, God knows what is causing this

User avatar
marmor
Registered User
Registered User
Posts: 5
Joined: Thu Dec 31, 2015 10:55 am
Flag: Sweden

Re: Chat problem

Post by marmor » Sat Jan 09, 2016 5:19 pm

Did not need to be so drastic, i compered old with new forum settings and found the problem, for anyone having this problem turn of URL Rewriting: under server settings, works like a charm after that :)
ty spaceace for this mod and for trying to help
Last edited by marmor on Sat Jan 09, 2016 5:20 pm, edited 1 time in total.

User avatar
spaceace
Site Owner
Site Owner
Posts: 908
Joined: Wed Dec 16, 2009 8:30 pm
Location: Ontario, Canada
Flag: Canada
Contact:

Re: Chat problem

Post by spaceace » Sat Jan 09, 2016 6:07 pm

that is very odd as i have the url rewrite turned on in the site i tested it on
if you like my work and would like to contribute to my development of styles, please donate by using the donate button in the header.

Image

Image

User avatar
Draecal
Newly Registered User
Newly Registered User
Posts: 1
Joined: Thu Apr 14, 2016 2:59 pm
Flag: Ireland

Re: Chat problem

Post by Draecal » Thu Apr 14, 2016 3:08 pm

Well, same error to my site, I write something and goes nowhere, blank chat. Also browser console, does not shows any error.

PHPbb Version: 3.1.8
AJAX Chat Version: 3.0.0
Server Type: Nginx
Url rewriting: Tested both, enabled and disabled.

* All permissions guaranteed.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests